Adobe Reader – TTF Font Dictionary Parser – Type Confusion – Memory Corruption

Vulnerability

Adobe Reader Type Confusion – Memory Corruption Vulnerability

Vulnerability Description

This vulnerability allows remote attackers to execute code on vulnerable installations of Adobe Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of TTF Font dictionary within a PDF file. The issue results from the lack of proper validation of user-supplied data. An attacker can leverage this vulnerabilities to execute code (RCE) in the context of the current process.

CVE ID

CVE-2017-3038

Vendor

http://www.adobe.com/

Products

  • Adobe Acrobat 11.0.19
  • Adobe Acrobat DC 15.006.30280
  • Adobe Acrobat DC 15.023.20070
  • Adobe Acrobat Reader DC 15.006.30280
  • Adobe Acrobat Reader DC 15.023.20070
  • Adobe Reader 11.0.19

Disclosure Timeline

  1. 05 December 2016 – Reported to vendor
  2. 06 April 2017 – Coordinated public release of advisory

Credits

Ashfaq Ansari – Project Srishti

Vendor Advisory

https://helpx.adobe.com/security/products/acrobat/apsb17-11.html

 

Leave a Reply

Your email address will not be published. Required fields are marked *

3 × one =